New Topic

Sidebars not showing on Blog Page

Home › Forum › Help › Sidebars not showing on Blog Page

This topic contains 15 replies, has 2 voices, and was last updated by  StartupWP 1 year, 9 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1963

    asccoder
    Member

    Hi again,

    The left and right sidebars aren’t showing on my blog page of the site at http://www.theasccoder.com/?page_id=9

    I have the page template type set as “Sidebar Left and Right”.

    Thank you.

    #1964

    StartupWP
    Support

    Page templates are a page-by-page option, not a universal design option.

    However, we can help you accomplish this utilizing a child theme:

    https://startupwp.com/topic/child-theming/

    Let us know if you decide to setup a child theme and we’ll instruct further.

    #1965

    asccoder
    Member

    I thought I had installed the child theme but I guess not. So yes, I would like to go ahead with the child theme :)

    #1967

    asccoder
    Member

    I’ve installed and activated the child theme. Will await further instructions :)

    #1969

    StartupWP
    Support

    1. Add the following to the bottom of your child theme’s stylesheet:

    body #content {
      padding: 4% 0 !important;
    }

    2. From the parent theme, copy over 404.php, archive.php, attachment.php, author.php, category.php, index.php, page.php, search.php, single.php, tag.php to your child theme.

    3. Open them all up in either TextWrangler (for Mac), Notepad++ (for Windows) or whatever your favorite editor is.

    4. Do a find and replace in all files for:

    <section id="content" role="main">

    with:

    <aside id="lsidebar-sidebar" role="complementary">
    <?php if ( is_active_sidebar( 'lsidebar-widget-area' ) ) : ?>
    <div id="lsidebar" class="widget-area">
    <ul class="xoxo">
    <?php dynamic_sidebar( 'lsidebar-widget-area' ); ?>
    </ul>
    <div class="clear"></div>
    </div>
    <?php endif; ?>
    </aside>
    <section id="content" role="main">

    5. Then do another find and replace in all files for:

    <?php get_sidebar(); ?>

    with:

    <aside id="rsidebar-sidebar" role="complementary">
    <?php if ( is_active_sidebar( 'rsidebar-widget-area' ) ) : ?>
    <div id="rsidebar" class="widget-area">
    <ul class="xoxo">
    <?php dynamic_sidebar( 'rsidebar-widget-area' ); ?>
    </ul>
    <div class="clear"></div>
    </div>
    <?php endif; ?>
    </aside>

    6. Save your child theme, upload and activate.

    #1970

    asccoder
    Member

    Ok I did all of the above and it hasn’t changed anything. Not sure what I’m doing wrong :(

    #1971

    StartupWP
    Support

    The child theme has broken style:

    
    /*
    Theme Name: StartupPro Child
    Template: startuppro
    */
    
    @import url("../startuppro/style.css");body #content {<br>
      padding: 4% 0 ;<br>
    }

    Should be:

    /*
    Theme Name: StartupPro Child
    Template: startuppro
    */
    
    @import url("../startuppro/style.css");
    
    body #content {
      padding: 4% 0 !important;
    }
    #1972

    asccoder
    Member

    I went into Editor > startup pro child: stylesheet (style.css) aand put in the above code. Still nothing :(

    #1974

    StartupWP
    Support

    Let’s go ahead and switch over to email for a moment:

    https://startupwp.com/contact/

    Make sure to include this topic link (https://startupwp.com/topic/sidebars-not-showing-on-blog-page/) in your message.

    Thank you.

    #1975

    StartupWP
    Support

    Yes, see what’s wrong.

    You have a sub-folder within the child theme folder /startuppro-child/ that contains all the php templates.

    You need to simply drag them out of that folder so that everything appears alongside style.css, delete the sub-folder, delete out the currently live child theme and re-upload the new one.

    You could zip it and install under Appearance > Themes, but a better way would be via FTP (if you’re not sure how to FTP into your site, please check with your host). The reason being is because that way you can make edits locally and then upload the changes to your live site so that you always have a backup and also because it’s much easier to edit files locally using a more advanced text editor than editing through the default WordPress file editor.

    #1977

    asccoder
    Member

    I did all that and now the blog looks worse. I would like a refund issued immediately.

    #1978

    StartupWP
    Support

    Something must still be wrong with your child theme, we’ve just prepared and tested the following and it’s verified working:

    https://startupwp.com/downloads/support/startuppro-child%28sidebar-left-right-universal%29.zip

    Please give that a try. If it’s still not to your satisfaction it’s likely that it just needs some more custom CSS for your specific site to refine.

    Also, please remember to now use Left Sidebar Widget Area and Right Sidebar Widget Area respectively under Appearance > Widgets.

    You’re unlikely to find any other company that provides the amount of support we do elsewhere so we hope you’ll give it some more time, but if you’re still not satisfied, we’ll get you refunded.

    Thank you.

    #1979

    asccoder
    Member

    Thank you so much. It looks wonderful. I won’t be needing a refund. Thank you again. I agree the support here to beyond compare.

    The only thing I need to change are the colors:

    1. The blue menu background, widget titles and header title “The ASC Coder” all to maroon hex code #800000.

    2. The body text to black.

    #1980

    StartupWP
    Support

    Also add:

    .page-template-templatestemplate-sidebar-none-php #content, .post-template-templatestemplate-sidebar-none-post-php #content, .page-template-templatestemplate-login-php #content, .post-template-templatestemplate-login-post-php #content {
      padding: 4% !important;
    }

    For the new layout changes.

    1. Use:

    #menu {
      background-color: #800000;
    }
    #site-title a, #site-title h1 a, #site-title h1, h1, h2, h3, h4, h5, h6, h1 a, h2 a, h3 a, h4 a, h5 a, h6 a {
      color: #800000 !important;
    }

    2. Great, looks like you already figured out this one:

    .entry-content p {
      color: #000;
    }

    3. Bonus tip. Go to Settings > Permalinks > Change to “Post name” > Save Changes

    What this will do is change links like:

    http://www.theasccoder.com/?page_id=21

    to “pretty” links like so:

    http://www.theasccoder.com/disclaimer/

    #1981

    asccoder
    Member

    Thank you for ALL your help…it is much appreciated :)

    #1982

    StartupWP
    Support

    You’re welcome.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.