New Topic

Photos on Ipad are too large

Home › Forum › Help › Photos on Ipad are too large

This topic contains 10 replies, has 2 voices, and was last updated by  StartupWP 1 year, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2136

    Posts viewed on a desk top look great, but when viewing on an Ipad the photos appear too large. They overlap into the side bar and other words and images appear on top of the photo. How do I adjust?
    beyondthechickencoop.com

    #2138

    StartupWP
    Support

    Here’s the complete code that appears in that page/post:

    <div class="wp-caption aligncenter" style="width: 650px" id="attachment_412"><a href="http://www.beyondthechickencoop.com/wp-content/uploads/2015/02/Chopped-Chicken-Salad.jpg"><img width="640" height="480" alt="Oriental Chopped Chicken Salad" src="http://www.beyondthechickencoop.com/wp-content/uploads/2015/02/Chopped-Chicken-Salad.jpg" class="size-full wp-image-412"></a><p class="wp-caption-text">Oriental Chopped Chicken Salad</p></div>

    Removing style="width: 650px" should be good enough.

    In responsive design you want to avoid setting fixed pixel widths.

    #2140

    How do I prevent this from happening with each post? Is there something I can do to prevent this from happening?

    #2143

    StartupWP
    Support

    You might try:

    .wp-caption {
      width: 100% !important;
    }

    https://startupwp.com/topic/customizing-your-theme/

    #2148

    Please give me more details. This may seem really simple to you, but I’m afraid I haven’t a clue how to do this. I can’t even find the exact code that you say is for my picture. I find something similar when I go to edit the post and then to text. I see similar language, but not that exact wording. The above directions aren’t enough for me to understand.

    Isn’t there a way when I upload pictures to make them responsive, or perhaps on the template itself?

    Thank you.

    #2150

    StartupWP
    Support

    1. Log into your WP admin.

    2. From the main menu on the left, navigate to:

    Appearance > StartupPro Options > Advanced Editing > Custom CSS

    3. Paste in:

    .wp-caption {
      width: 100% !important;
    }

    4. Click “Save Options”.

    #2152

    Thank you for the detailed directions. I was able to follow them and paste the code, however, I do not see any changes on the pictures when viewing on an Ipad. Is there anything else I need to do?
    Thank you.

    #2154

    StartupWP
    Support

    Doesn’t look like the CSS is being applied.

    After adding code make sure to clear all caches, specifically if you’re using a WordPress caching plugin.

    #2156

    StartupWP
    Support

    Fixed.

    There was an error in your CSS and “Custom Styles & Custom CSS” wasn’t turned on.

    #2159

    Thank you so much! The pictures are much better.

    #2162

    StartupWP
    Support

    You’re welcome.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.